易语言取外网ip的两种方法

易语言取外网ip的两种方法

方法一:

.版本 2
.支持库 internet

.子程序 取外网ip_文本操作, 文本型
.局部变量 内容, 文本型
.局部变量 开始位置, 整数型
.局部变量 长度, 整数型
.局部变量 网址, 文本型
.局部变量 开始标识符, 文本型
.局部变量 结束标识符, 文本型

网址 = “http://www.net.cn/static/customercare/yourIP.asp”
开始标识符 = “<h2>”
结束标识符 = “</h2>”
内容 = 到文本 (HTTP读文件 (网址))
开始位置 = 寻找文本 (内容, 开始标识符, , 假) + 取文本长度 (开始标识符)
长度 = 取文本长度 (内容) - 取文本长度 (开始标识符) - 寻找文本 (内容, 开始标识符, , 假) - (取文本长度 (内容) - 寻找文本 (内容, 结束标识符, , 假))
返回 (取文本中间 (内容, 开始位置, 长度))

方法二:

.版本 2
.支持库 RegEx
.支持库 internet

.子程序 取外网ip_正则操作, 文本型
.局部变量 开始标识符, 文本型
.局部变量 结束标识符, 文本型
.局部变量 正则, 正则表达式
.局部变量 结果, 搜索结果
.局部变量 内容, 文本型
.局部变量 网址, 文本型

开始标识符 = “<h2>”
结束标识符 = “</h2>”
网址 = “http://www.net.cn/static/customercare/yourIP.asp”
正则.创建 (开始标识符 + “(.*?)” + 结束标识符, 假)
内容 = 到文本 (HTTP读文件 (网址))
结果 = 正则.搜索 (内容, 1, )
返回 (结果.取子匹配文本 (内容, 1, ))

评论功能被我吃了。